View Issue Details

IDProjectCategoryView StatusLast Update
0003333OXID eShop (all versions)4.09. SEO, SEO URLpublic2012-12-10 13:34
ReporterArunas 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.4 revision 39463 
Target Version4.5.5 revision 40299Fixed in Version4.5.5 revision 40299 
Summary0003333: EE ONLY: oxSeoEncoderArticle::_getMainCategory() returns an empty oxCategory object which then makes ugly seo links
DescriptionoxSeoEncoderArticle::_getMainCategory() returns and empty oxCategory object.

This is because of the trash left in `oxobject2article` table on Enterprise Edition, when partial imports of data might have been done on the database.
This sometimes leaves outdated values in OXSHOPINCL field.

The method gets a category ID that shouldn't be available on a particular
subshop and then tries to load it, which ends up as an empty object to return
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

Arunas

2011-10-28 16:42

reporter   ~0005352

fixed, now in case the main category load failed, returns null