View Issue Details

IDProjectCategoryView StatusLast Update
0003307OXID eShop (all versions)4.06. Language and translationspublic2012-05-03 11:45
Reporterray 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.2 revision 38481 
Target VersionFixed in Version4.7.0_5.0.0_beta1 
Summary0003307: only englisch month-names available in order-history
DescriptionIf a customer checks his order history he can only see the english month names. It seems that the names are hardcoded in datasource-min.js and jquery-ui.min.js.

As we decided - showing the months names would be more complex solution and may depend on several topics. So proper solution would be to display month numbers instead of month names in Azure, as is already in Basic.
Additional Informationsee thread in forums with screenshot:
http://www.oxid-esales.com/forum/showthread.php?p=70684#top
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

ray

2011-10-13 10:39

reporter   ~0005304

Last edited: 2011-10-13 10:40

View 2 revisions

or is it maybe due to the php setting for "locale"?

holgt

2011-10-13 11:33

reporter   ~0005305

well actually i did a proof : changing the locale settings, in deed changes the output, according to the settings, which is to be expected, because in the end the output comes from php strftime

ray

2011-10-13 22:22

reporter   ~0005313

But - this means they month names are always shown as per php locale setting?

So what happens, if someone uses a multi-language-shop? Does it always show the month-names according to default locale settings? Or do the settings switch according to the active shop-language?

arvydas_vapsva

2012-01-24 13:11

reporter   ~0005642

Yes, its a bug. But solution with locale setting looks more like a workaround and we just cant implement it in shop (may not work on various configurations etc). The better idea would be to stay with numeric format date like it is in "basic" theme, but enable possibility to customize visibly formatted date: e.g.:

[{assign var="sOrderDate" value="ORDER_DATE"|oxmultilangassign}]
[{$order->oxorder__oxorderdate->value|date_format:$sOrderDate}]

and value of "ORDER_DATE" constant would be any preferred format (e.g. same old "%B %e, %Y") according to country formatting rules.

dainius.bigelis

2012-03-09 17:52

reporter   ~0005940

We decided to stay with numeric format date like in basic theme. For those who want custom format - please use these snippets posted in previous comment.

ray

2012-04-30 23:04

reporter   ~0006490

so can you choose now as a shop admin how to display the date - e.g. american or european format?

saulius.stasiukaitis

2012-05-03 09:45

reporter   ~0006499

Changed from month name to germany date format d.m.Y as in all eshop frontend.
From:
[{ $order->oxorder__oxorderdate->value|date_format:"%B %e, %Y" }]
To:
[{ $order->oxorder__oxorderdate->value|date_format:"%d.%m.%Y" }]

ray

2012-05-03 10:18

reporter   ~0006500

Last edited: 2012-05-03 10:18

View 2 revisions

same issue in Download-History in 4.6.0 - please change to numeric format as well

saulius.stasiukaitis

2012-05-03 11:45

reporter   ~0006501

Tx, fix it.

date_format:"%d.%m.%Y" add to basic and azure templates: page/account/downloads.tpl
Now it is:
[{ $oOrderArticle.oxorderdate|date_format:"%d.%m.%Y" }]

We also add suggestion to uservoice to improve shop changing date, currency or numbers separators by user regional.
http://oxid.uservoice.com/forums/31940-feature-requests/suggestions/2821288-shop-should-taken-into-account-user-country-when-