View Issue Details

IDProjectCategoryView StatusLast Update
0003261OXID ERP InterfaceOXID ERP Interface - subpublic2012-10-31 13:50
Reporterkrzysztof.mrzyglod 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.8.0_31492 
Target VersionFixed in Version2.11.0_52702 
Summary0003261: Access of undefined properties
DescriptionIn class "oxerpgateway" there are several methods which are trying to access to undefined properties:

PHP Notice: Undefined property: stdClass::$iStart in /modules/erp/oxerpgateway.php on line 740
PHP Notice: Undefined property: stdClass::$iStart in /modules/erp/oxerpgateway.php on line 1062
PHP Notice: Undefined property: stdClass::$sIn in /modules/erp/oxerpgateway.php on line 1520
PHP Notice: Undefined property: stdClass::$iStart in /modules/erp/oxerpgateway.php on line 983
PHP Notice: Undefined property: stdClass::$iStart in /modules/erp/oxerpgateway.php on line 1367
TagsNo tags attached.

Relationships

related to 0003264 resolvedarvydas_vapsva OXID eShop (all versions) Access of undefined property/index/offset 

Activities

dainius.bigelis

2011-10-14 16:32

reporter   ~0005321

eShop itself forces php option to not shown the PHP notices as not all of these can be solved in some cases. Also notices may occur because the 3rd party modules installed.
Some of these notices should be checked and solved as it also may make affect for eShop performance. So the entry here is left for deeper investigation, but the priority and severity are minor.

arturas.sevcenko

2012-10-31 13:50

reporter   ~0007690

checked for redundant notices