View Issue Details

IDProjectCategoryView StatusLast Update
0003182OXID eShop (all versions)2. ----- eShop backend (admin) -----public2011-09-05 11:42
Reportertjungcl 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPast development 
Target VersionFixed in Version4.5.3 revision 39087 
Summary0003182: cant create new attribute in admin
Descriptionwhen trying to add a new attribute, the name and sort boxes seem to be readonly.

Creating a new attribute is only possible by clicking save with empty fields and than editing the newly created empty attribute.



TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

birute_meilutyte

2011-08-25 14:40

reporter   ~0005108

Reminder sent to: tjungcl

Hello,

sorry, but i can not reproduce the problem on our latest development version. could you please let us know, in which eShop version and revision you experience such behaviour?

greetings,
Birute

tjungcl

2011-08-25 14:46

reporter   ~0005109

Yes, I currently run 4.5.1 revision 38202 and I can also reproduce the issue in your demoshop.

I tried another browser and there it works - it seems, the issue only happens in google chrome (could only test latest dev build of chrome).

birute_meilutyte

2011-08-25 16:28

reporter   ~0005115

Reminder sent to: tjungcl

sorry, but i still can not reproduce this problem (neither on our development version nor on demoshop). i am using Chrome version 13.0.782.215 (which is the latest one) for Windows.

just to be sure, attributes for you are not working in Administer products -> Attributes -> Create new attribute ?

tjungcl

2011-08-25 16:37

reporter   ~0005116

Yes, exactly. I submitted a screenshot where the place is highlighted. When i hit my keyboard in this field, nothing happens.

I run the dev build of chrome which can be found on http://www.chromium.org/getting-involved/dev-channel

I have no chrome extensions active.

tjungcl

2011-08-25 16:37

reporter  

attribut.PNG (37,702 bytes)
attribut.PNG (37,702 bytes)

birute_meilutyte

2011-08-25 16:51

reporter   ~0005118

Reminder sent to: tjungcl

the problem appears only with dev Chrome version, which is not official or released. we tested with other browsers (IE, Firefox, Chrome latest released version, Safari, Opera) and such problem can not be reproduced. therefore this bug here will be closed.

tjungcl

2011-08-25 17:04

reporter   ~0005119

Sorry, for reopening!
You are right, since it is no released browser, there is no need of a fix.

However, that it doesnt work in a dev build is a good hint, that something is not optimal there.

I had a second look and the problem is, that the input field is missing a value in 'maxlength=""'

It seems, this is interpreted as 0, making the field readonly, which is a bug in chrome, but can easily be avoided by giving a value like maxlength="255" or removing the maxlength completely.