View Issue Details

IDProjectCategoryView StatusLast Update
0003175OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterclaro 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.1 revision 38045 
Target VersionFixed in Version4.6.0_beta3 
Summary0003175: Code of Newsletter template is changed/broken after saving newsletter template more than once
DescriptionIf you have html-Code in newsletter template text (admin/customer info/newsletter) and you save the newsletter template text more than once, some part of the html-code will be erased after the saving process.
After this, the Newsletter will display only one article of promotions/newsletter but this one twice.

This Bug is there since version 4.4.8
Steps To Reproducein demoshop:
1) add three articles to promotions/newsletter
2) go to customer info/newsletter and chose "Beispiel Newsletter"
3) go to preview-tab and you will see the three articles displayed
4) go to HTML-tab and change "Hallo Mr John Doe," to "Hi" and push the SAVE-button
5) go to preview-tab and you will see only one articles but displayed twice.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0003280 resolvedrimvydas_paskevicius example newsletter doesn't work 
related to 0003212 resolvedrimvydas_paskevicius No Images in Newsletter 

Activities

rimvydas_paskevicius

2011-12-21 15:24

reporter   ~0005521

Newsletter templates were rewritten from scratch to look like azure theme emails. This will help to avoid conflict between smarty tags and wysiwyg pro editor which was causing this problem (messed html code after save).