View Issue Details

IDProjectCategoryView StatusLast Update
0003106OXID eShop (all versions)4.05. Performancepublic2012-12-10 13:29
Reporterwebtools 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.6.0_beta2 
Summary0003106: Indizes in oxarticle etc.
DescriptionHi,

watching the querys made for example within selects at the oxarticle-table, I found a performance improvement by creating an index over the field oxsoldamount.

Setting an Index (localhost development environment) at this field i won several seconds.

Before ca. 10 secondes, after 0,002 seconds

"select * from oxv_oxarticles_de where ( oxv_oxarticles_de.oxactive = 1 ) and oxv_oxarticles_de.oxissearch = 1 and oxv_oxarticles_de.oxparentid = '' and oxv_oxarticles_de.oxsoldamount>0 order by oxv_oxarticles_de.oxsoldamount desc limit 5"

This issue seems to be important within bigger article-tables up to 100.000 articles ;-)

Perhaps it makes sense for you to check the indizes or for indixes which do not exist ;-)
TagsPerformance
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

svetlana

2011-08-11 15:53

reporter   ~0004997

@developers: please investigate from source code side

Linas Kukulskis

2011-08-12 15:29

reporter   ~0005018

added index