View Issue Details

IDProjectCategoryView StatusLast Update
0003084OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
Reporterpythagoras 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.2 revision 38481 
Summary0003084: Alternative Template instead of the "details.tpl" for special articles doesn't work (Alt. Template)
DescriptionFor some article i need an alternative template. For that you have in the admin area (-> article) the field "Alt. Template".
But for example my second template is "details_gs.tpl" and i save it in the same register like the main template "details.tpl". I filled the "alt. template" with "detals_gs.tpl".
The article can't access to (details_gs.tpl).
Steps To Reproduce1. copy "details.tpl" in the same content to "xxx.tpl"
2. chance for example some text in the template "xxx.tpl"
3. login in the Shop -> go to "article" -> go to "alt. template"
4. fill the "alt. template" with "xxx.tpl"
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

Arunas

2011-08-12 10:55

reporter   ~0005008

Last edited: 2011-08-12 11:06

View 2 revisions

not a bug, the structure of the template directory has changed since 4.5.0 so right now you have to write in the full path to the file, like this "page/details/details_new.tpl".
The outdate documentation will be changed

pythagoras

2011-08-12 12:40

reporter   ~0005011

Thanks a lot! It works.

juergen_busch

2011-08-25 11:54

developer   ~0005105

Information was changed in:
* online documentation
* out\admin\en\help_lang.php
* out\admin\de\help_lang.php