View Issue Details

IDProjectCategoryView StatusLast Update
0003075OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:16
Reportertomas_liubinas 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0003075: Active subshop ID value is dropped from session, default shop id is set
DescriptionActive subshop ID is dropped from session and "shp" URL parameter (or different domain for subshop) is always required for every subshop call. Otherwise active shop ID value is set to the default (1). This is a problem for already implemented ERP, partially eFire and possibly other 3rd party connections working with subshops! Normal scenario for such calls up until version 4.5.0 was setting shopid first followed by generic URL calls later.

I also would like to note that this behavior is actually correct because this way URLs are not ambiguous anymore, plus we can load config data (correctly) before session has been initialized now. However the problem for external connections persists and needs to be solved. Probably we need some backward compatibility flag included into config.inc.php here.
Additional InformationPlease post the flag parameter name here in case we decide to implement it. Name it making clear that this parameter is intended for backward compatibility (smth like blDeprecatedSessionSubshops).
TagsSubshops
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005711 assignedflorian.auer oxConfig::getShopId() doesn't return shop id from session because session isn't opened before querying it 
related to 0006064 acknowledgedflorian.auer Login in subshop is valid in the parent shop 

Activities

Linas Kukulskis

2011-07-27 17:29

reporter   ~0004894

added compatibility parameter blDeprecatedSubshopsInSessions in config.inc.php
added fix in oxConfig method getShopId.