View Issue Details

IDProjectCategoryView StatusLast Update
0003016OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-07 15:17
Reportertjungcl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.6.0_beta2 
Summary0003016: other payment method without costs show (0,00 €) in label
Descriptionthe reason is, that in the tpl the condition is
[{ if $paymentmethod->fAddPaymentSum}]

where it should be

[{ if $paymentmethod->dAddPaymentSum}]

fAddPaymentSum returns 0,00 in german (with a comma), which is interpreted by smarty as a string and so returns true, while dAddPaymentSum returns the double 0.00 in all alnguages
TagsPayment
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

birute_meilutyte

2011-07-06 12:54

reporter   ~0004828

@developers: check if offered solution is correct

alfonsas_cirtautas

2011-08-30 16:04

reporter   ~0005144

fixed payment price display conditions