View Issue Details

IDProjectCategoryView StatusLast Update
0002991OXID eShop (all versions)4.06. Language and translationspublic2012-01-23 17:17
ReporterHelmut L. 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.7 revision 41909 
Summary0002991: wrong language is detected with similar language urls
Descriptionif you have two languages:
russian http://www.example.net.ru
turkish http://www.example.net

and open the URL http://www.example.net the shop will detect the language Russian
Steps To ReproduceGive two languages an URL.
The first language should have a longer version of the second URL.
Additional InformationThe problem is in the isCurrentUrl function of oxConfig. Here is strpos used to search for the current URL in the URL of the language and the current shorter URL will always be found in the longer language URL.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2012-01-23 17:17

reporter   ~0005630

added additional check of domains