View Issue Details

IDProjectCategoryView StatusLast Update
0002925OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2011-06-22 14:17
Reportereike_spriess 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002925: Changes in CMS Pages of a subshop are saved for all Subshops.
DescriptionIf customer changes CMS page in one subshop e.g. "About us", it is saved for all subshops. So all subshops have the same CMS page "About us".
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0002842 resolvedvilma_liorensaityte wrong shopid in admin 
related to 0002875 resolvedvilma_liorensaityte oxConfig::mustAddShopIdToRequest() does not check admin state (EE only) 

Activities

Moehlis

2011-05-23 15:17

reporter   ~0004645

Last edited: 2011-05-23 15:18

View 2 revisions

i checked on 4.5.0 34568 but could not reproduce. maybe your subshop inherits the cms from another subshop?

101-oxid-bugs

2011-05-23 18:38

reporter   ~0004648

no, subshop does not inherit the CMS and it's not only for CMS, but for basically all shop objects. It's an absolut BLOCK severity, not minor !

IMPORTANT: Enter any URL for the sub shop, compare with my note at https://bugs.oxid-esales.com/view.php?id=2842 - it's exactly the same cause, but MUCH worse impact

dainius.bigelis

2011-06-22 14:17

reporter   ~0004756

Fixed together with 0002875