View Issue Details

IDProjectCategoryView StatusLast Update
0002794OXID eShop (all versions)1.05. Userspublic2011-05-09 17:03
Reportertabsl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002794: orderslist in account_order
Descriptionmy account --> orders

only shows the last order

$oView->getOrderList()|count ist right, e. g. 3, but only shows the last one
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0002843 resolvedLinas Kukulskis users order history shows only last order in frontend 

Activities

rrosendahl

2011-04-29 11:34

reporter   ~0004418

As a workaround, you can move the line

[{assign var=oArticleList value=$oView->getOrderArticleList() }]

out of the foreach loop to the beginning of the file, above

[{foreach from=$oView->getOrderList() item=order }]

The products will then be fetched before the orders. Apparently there is some iterator messup because the $this->getOrderList() in account_order is being reused there...

Linas Kukulskis

2011-05-09 17:03

reporter   ~0004524

dublicate