View Issue Details

IDProjectCategoryView StatusLast Update
0002691OXID eShop (all versions)4.06. Language and translationspublic2011-04-29 16:25
ReporterHelmut L. 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0_beta4 
Target VersionFixed in Version4.5.0 revision 34568 
Summary0002691: the language fields are always added to the main table
DescriptionIf you add the 9. language, according to OXID forge (http://wiki.oxidforge.org/Language_handling_from_eShop_v4.5.0), the fields should be added to the table oxarticles_set1.
But instead the fields are added to oxarticles.

If UTF8 encoding is used, also the max row size is after OXSTOCKTEXT_8 reached and OXNOSTOCKTEXT_8 can not be added.

In the admin also appears no error message about the field OXNOSTOCKTEXT_8.
The function call to add the fields is in a try catch block, but for adding the fields adodb is used, which dose not throw exceptions and instead only returns false.
Steps To ReproduceGo to the languages into the admin.
There are already the default languages "Deutsch" and "English".
Now add seven additional languages.
If you look now in the database you will find no oxarticles_set1 table and instead find the OXTITLE_8 field in oxarticles.

If you installed the beta in UTF8, you can also see that the field OXNOSTOCKTEXT_8 is completely missing.

Additional InformationEnterprise Edition
/core/oxdbmetadatahandler.php
There seems to be no place where the tables for the language fields are created.

/admin/language_main.php, line 402
try catch for a function that does not throw an exception
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

birute_meilutyte

2011-04-29 16:25

reporter   ~0004427

this problem was fixed for final 4.5.0 version