View Issue Details

IDProjectCategoryView StatusLast Update
0002686OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reportertjungcl 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.8 revision 34028 
Target VersionFixed in Version4.7.0_5.0.0_beta1 
Summary0002686: Manufacturer product number OXMPN too short
Descriptionvarchar(16) is too short for a third of our products.

Since we have many extraordinary products (and manufactures), the mpn is often of descriptive nature.

For example those two versions of an article:
Art.163/Col.66/47x47cm/x6
Art.163/Col.0/150x150cm/x2

I suggest varchar(100) to be on the safe side.
(Our most extreme products mpn is actually that long...)
Additional Informationoxmpn is required from 3. May 2011 on (if you dont have eans)
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2011-04-05 10:23

reporter   ~0004317

Reminder sent to: tjungcl

Hi,

This is more feature request, not a bug. So it's moved to the feature request list:
https://oxid.uservoice.com/forums/31940-feature-requests/suggestions/1677421-manufacturer-product-number-oxmpn-too-short

Thank you for report.

tjungcl

2012-04-27 11:32

reporter   ~0006472

I again forgot to modify this field after installation and loaded thousands of mpns, that were then cut of after 16 chars.

The feature request user-voice-suggestion list is kind of a joke.
I reopen this by quoting the only user-reaction in a whole year (my own):

---

Moved to feature request for something so trivial?

Making this field 16 chars long in the first place was just a design-flaw. There is no need to restrict this field to so few chars. Even Oxids own artikelnumbers OXARTNUM is varchar(255)!

Of course everybody can change the type to varchar(100) on his own (has i have done of course), but you could include that in your next update, so other users just dont have to bother.

Linas Kukulskis

2012-05-14 16:07

reporter   ~0006598

changed to 100