View Issue Details

IDProjectCategoryView StatusLast Update
0002611OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reportercpjolly 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version4.5.0_beta3 
Target VersionFixed in Version 
Summary0002611: ERP interface not updated for new language handling
DescriptionThe ERP functions have not been updated to work with the new language view system. The 4.5.0_beta3 and 4.4.7 files in core/objects/oxerp*.php and core/oxerp*.php are the same. I think this means the OXID SOAP-interface, CSV import/export and third party ERP interfaces will not work with 4.5.0.

For example, see line 156 of objects/core/oxerptype.php. The function call to getViewName( $this->_sTableName, $iShopID ) has two paramters. The new version of getViewName in oxfunctions line 450 has three parameters, and the second parameter is now the language, not shopID.

The ERP functions are record based, not language based, so there needs to be support in the ERP interface for access to the full record, with all fields. This could be via the new base views (eg oxv_oxarticles) not the language specific views (eg oxv_oxarticles_de).
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0002618 resolveddainius.bigelis Generic export doesn't work when changed the default language 
related to 0002706 resolvedLinas Kukulskis Product Export exports data only in DE language 

Activities

cpjolly

2011-03-13 15:52

reporter   ~0004223

Last edited: 2011-03-13 15:54

View 4 revisions

TYPO...

the referenced line should be line 156 of core/objects/oxerptype.php

Linas Kukulskis

2011-04-19 14:16

reporter   ~0004371

these classes is used only for import functionality in admin. and they don,t need to be updated.
when import will be re-factored they will be removed and cleanup.

cpjolly

2011-05-07 17:54

reporter   ~0004509

Sorry, I don't understand the resolution. This class is used by the OXID SOAP ERP interface and by many 3rd party modules, so it must be corrected.

dainius.bigelis

2011-05-11 14:34

reporter   ~0004544

Reminder sent to: cpjolly

Hi,

The problem is, that this part of code is in need of refactoring and cleaning and improving from functionality side. Currently we fixed the issues, to make Product export and Generic Import working and compatible with rest of the code from 4.5.0 version (see issues 2618 and 2706). But we didn't any big changes or improvements now, because in one of closest eShop versions we will, probably, rebuild some parts in this functionality from scratch.

Best regards,