View Issue Details

IDProjectCategoryView StatusLast Update
0002569OXID eShop (all versions)3.1. Design, GUI, UXpublic2011-07-05 14:06
Reporterintertag 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0_beta3 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002569: Custom theme: image inheritance not working if img-folder is present in custom theme
DescriptionI have created a custom theme for the azure theme like described here:
http://wiki.oxidforge.org/Tutorials/Understanding_theme_management_in_OXID_eShop_from_4.5.0

Now the frontend references an image (myTheme/img/basket.png) which is not present in my custom theme. It is present in the original azure theme (azure/img/basket.png).

This only happens if the img folder in the custom theme existis.

I would expect an image within the custom theme only to be referenced, if it is present there and fallback to the original theme otherwise.
TagsNo tags attached.
ThemeBoth
BrowserFireFox 3.x
PHP Versionany
MySQL Version5.1

Relationships

related to 0003025 resolvedLinas Kukulskis regarding 0002569: no change required: issue not correctly handled 

Activities

birute_meilutyte

2011-05-20 09:26

reporter   ~0004627

Reminder sent to: intertag

Hello,

sorry, but i can not reproduce the case. Could you please let us know, if you still experience same problem with our latest eShop 4.5.0 revision 34568 release?

greetings,

leofonic

2011-05-23 21:19

reporter   ~0004649

Just create an empty src or img directory in a custom theme folder. While it is possible to create an empty tpl Folder and put only modified files in it, you have to copy the contents of src and img, because original folders are ignored if those folders are present in custom theme.

tjungcl

2011-06-09 11:00

reporter   ~0004723

Last edited: 2011-06-09 11:09

View 2 revisions

I experience this still in latest nightly build of 4.5.

As soon as out/mytheme/img exists, it is used for ALL img, wether they exist in mytheme or not.

I dont experience this for src, though.

Linas Kukulskis

2011-07-05 14:06

reporter   ~0004819

fixed theme image inheritance.
added parameter to get'er: $oViewConf->getImageUrl( $sFile );
all image get'ers in template must be changed to: [{$oViewConf->getImageUrl('basket.png')}]