View Issue Details

IDProjectCategoryView StatusLast Update
0002532OXID eShop (all versions)3.1. Design, GUI, UXpublic2011-09-26 13:15
ReporterBergfreunde 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version4.5.3 revision 39087 
Summary0002532: paging: empty list
DescriptionWhen a category has many products and several pages and you delete some products from that category, the other pages are still reachable by url and show an empty list (watch that bug: 0002516).

The bug shouldn't be fixed like that, because the pages are still reachable by url which might be already indexed by a search-engine.

To fix that accurate you should check if the called paging has articles and if not show a 404 - page not reachable.
Steps To Reproduce1. go to oxid-demoshop
2. place all products in one category
3. call category in frontend
4. remove nearly all products from category
5. call the category with a paging > 1
6. watch an empty category
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0002829 resolvedarvydas_vapsva behaviour of page number seo-urls inconsistent and in some cases wrong 

Activities

Bergfreunde

2011-02-17 10:50

reporter   ~0004124

Sorry - certainly it should be 404 - Not Found

birute_meilutyte

2011-04-29 16:46

reporter   ~0004428

Reminder sent to: Bergfreunde

Hello,

sorry, but i can not reproduce this case on the final 4.5.0 version. could you please check if you still have same problem on lates eShop version, or at least let us know for which eShop version you have reported this issue.

greetings,

Bergfreunde

2011-05-02 16:15

reporter   ~0004435

Hello,

the bug is still available in 4.5 and can be reproduced in your demoshop:
http://demoshop.oxid-esales.com/enterprise-edition/


When you visit

http://demoshop.oxid-esales.com/enterprise-edition/Wakeboarding/Wakeboards/2/

you get the message

"Fehler Die angeforderte Seite 'Wakeboarding/Wakeboards/2/' konnte nicht gefunden werden."

When you remove the products from category like I described under "Steps To Reproduce" and call this page you get an empty category-page instead of an error-message due to 404 - Not Found.

I hope its clear now.

Best regards,
Benni