View Issue Details

IDProjectCategoryView StatusLast Update
0002476OXID eShop (all versions)5. ------ UpdateApp / Update ------public2013-03-29 13:01
Reportertjungcl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.6 revision 32697 
Target Version4.6.7Fixed in Version4.7.4 / 5.0.4 revision 57063 
Summary0002476: Remove year from copyright line in header of source code files
DescriptionNow the change of year in the header of source file is considered in deployer as the change of source code itself. Because this reason all the source files are included in Patch packages as "changed" (even cust_lang.php and functions.php, which should not be included).
Remove year from copyright line in headers of source files (this line is added as tag for automatic replacement by SVN).
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2011-02-02 18:36

reporter   ~0004067

comment from tjungcl:
"I already found a report about overwritten cust_lang's that has status resolved, because cust_lang's are in the changed_full directory - ok.

But this time not only the cust_langs are replaced, but also the functions.php, which contains nothing but the copyright.

Many of those phpfiles that had been replaced in this patch had been replaced because of a updated copyright-year. Ok, you have to do that - but copyright on a file that contains nothing but user-defined functions?

You should really consider to remove the copyright from the functions.php as well as from the cust_lang files."

tomas_liubinas

2013-03-26 14:25

reporter   ~0008535

When generating update packages copyright year is ignored now.