View Issue Details

IDProjectCategoryView StatusLast Update
0002444OXID eShop (all versions)2. ----- eShop backend (admin) -----public2011-10-04 13:20
Reporterkickiss 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.4.1 revision 28950 
Target VersionFixed in Version 
Summary0002444: Malformed URL delete path - does not delete any files
Descriptionoxmediaurl.php
function delete()
$sFilePath - invalid formed
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0003185 resolvedLinas Kukulskis 404 after calling media data in frontend with https url 

Activities

Mitmacher

2011-04-13 16:39

reporter   ~0004361

I also noticed this some days ago and want to offer a solution. Inside of function delete() replace this:

$sFilePath = $this->getConfig()->getConfigParam('sShopDir') . "/out/media/" .
                     $this->oxmediaurls__oxurl->value;

with this:

$sFilePath = $this->getConfig()->getConfigParam('sShopDir') .
                     str_replace($this->getConfig()->getShopUrl(), '', $this->oxmediaurls__oxurl->value);

and all product media files can be deleted again without problems! :-)

birute_meilutyte

2011-05-11 09:24

reporter   ~0004542

@developers: check if such issue still exist and if offered solution can be useful

Mitmacher

2011-09-13 17:40

reporter   ~0005204

Last edited: 2011-09-13 17:42

View 2 revisions

Could someone please change the priority of this issue to high/major? (because the problem still exists in version 4.5.2!)
I wonder if nobody else has noticed this problem or simply don't use media files? ;)

vilma_liorensaityte

2011-10-04 13:20

manager   ~0005285

This problem should be solved with a fix of bug 0003185