View Issue Details

IDProjectCategoryView StatusLast Update
0002441OXID eShop (all versions)1.06. Search, Tagspublic2012-12-07 14:42
Reportermanuel 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.5 revision 31315 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002441: TagCloud is loaded even if not used
Descriptione.g. in details view.

the render-method loads all tags even if you don't need them.

it would be better to have the possibility to switch them off in performance area in the backend.
TagsTags
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

dainius.bigelis

2011-06-17 15:07

reporter   ~0004744

Actualy this is caused by "old style rendering" for old templates (which are now deprecated). Meaning - aView is generated on the render function. It should be rendered only on the getter. If the getter is removed from the templates, no tag cloud is generated and no performance lost.

arvydas_vapsva

2011-06-28 14:30

reporter   ~0004776

since version 4.5 tags are fetched only by getters

arvydas_vapsva

2011-06-28 14:31

reporter   ~0004777

added config parameter in admin "Master Settings > Core Settings > Settings > Shop frontend" to enable/disable tags. By default tags are ON