View Issue Details

IDProjectCategoryView StatusLast Update
0002397OXID eShop (all versions)3.1. Design, GUI, UXpublic2011-03-23 14:47
Reporterbirute_meilutyte 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.0_beta1 
Target VersionFixed in Version4.5.0_beta4 
Summary0002397: in frontend lists, selected category view method (line, grid, double grid) is not memorized
Descriptionin frontend lists selected category view method (line, grid, double grid) is not memorized. every time you click on new (or even the same) category, there is allways double grid view mode selected, no matter if different one was chosen before. with products per page setting everything works ok.
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

Linas Kukulskis

2011-01-28 15:38

reporter   ~0004027

it's seems was fix with other fixes

birute_meilutyte

2011-02-01 16:39

reporter   ~0004053

not working when caching is on

rimvydas_paskevicius

2011-02-01 16:45

reporter   ~0004054

Grids does not change because on reload page is taken from cache, which is not updated. Fixed method aList->getViewId(). Parameter "ldtype" must be included in view id when generating cache ID.

birute_meilutyte

2011-02-15 10:05

reporter   ~0004121

selected view mode is resetted after any action (changing page, adding to basket etc)

dainius.bigelis

2011-03-23 14:47

reporter   ~0004252

Fixed with some other bugfixes