View Issue Details

IDProjectCategoryView StatusLast Update
0002379OXID eShop (all versions)2. ----- eShop backend (admin) -----public2011-01-24 17:32
ReporterBergfreunde 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.3.2 revision 27884 
Target VersionFixed in Version4.4.6 revision 32697 
Summary0002379: User logout after login in admin area
DescriptionWe have the same Bug in 4.3.2 as reported in 0002201:

After a successfully login in the admin area, the user will be logout and forward to the login view, if you click on a menu entry.

Sometimes the failure disapears if you login several times.
Another hack is to clear the tmp folder.


####

It doesn't happens all the time. In our case between 06:30 and 07:00 a.m, but not everyday. It is because the oxeec_menu_de_xml.txt. if you delete that tmp it is working again.
The Problem ist that there is a admin_sid in the file! I can e-mail you a broken file if you want.

Unfortunately your Support didn't answer the question which action is generating a new version of this tmp-file?!
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2011-01-13 16:24

reporter   ~0003965

@Developers: please check the case regarding oxeec_menu_de_xml.txt, maybe it will give some hint about problem, as in previously reported bug 0002201 we were unable to reproduce such case.

sarunas_valaskevicius

2011-01-18 17:31

reporter   ~0003990

fixed in oxnavigationtree

Bergfreunde

2011-01-19 08:45

reporter   ~0003992

Could you please tell us what you fixed?

sarunas_valaskevicius

2011-01-20 16:08

reporter   ~0004003

Last edited: 2011-01-20 16:09

View 2 revisions

fixed menu xml file caching by changing the workflow which ensures the links in the cached xml are clean

Bergfreunde

2011-01-20 16:40

reporter   ~0004004

Hello,

we have those login problems every morning so we don't want to wait until next update because it is really annoying to delete this file from temp every morning.

As the changes don't seem to be in the last nightly built we don't know what we have to change in the code. We would be deeply grateful when you could publish the exact changes here.

dainius.bigelis

2011-01-24 17:31

reporter   ~0004012

Reminder sent to: Bergfreunde

Hi,

The fix for this issue will be included in the upcomming Patch, which will be released tomorrow. So when this will be published - please Patch your shop to latest version and the issue should gone.

Best regards,