View Issue Details

IDProjectCategoryView StatusLast Update
0002357OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 13:23
ReporterAlxPick 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version4.4.5 revision 31315 
Target VersionFixed in Version 
Summary0002357: categories and article assignment, wrong calculation of delivery costs
DescriptionSomething is wrong with the general math if categories or articles are assigned to a rule (this is similar to my previous reported bug).


Steps To ReproduceExample:
- 2 rules for delivery costs, both have different articles assigned to each other

If one article of each group is in the basket, no rule gets calculated, delivery costs are 0

Same problem goes for categories assigned to the rule.
TagsOrder
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0002149 resolvedarvydas_vapsva Higher shipping cost for certain articles does not work 

Activities

dainius.bigelis

2011-01-14 16:01

reporter   ~0003973

Last edited: 2011-01-14 16:05

View 2 revisions

Reminder sent to: AlxPick

hi,

I checked this case. To describe in details:
1. I created the shipping set rule, which costs 10 EUR, and have product assigned No.2275. Also shipping Method for it.
2. Then created second shipping set rule, which costs 20 EUR and have product No.1651 assigned.
When there are any of these products (only one of these) in the basket - appropriate Shipping Method is displayed (that's ok).
3. then I add both products (2275 and 1651) to the basket. In the third order step I don't see any of newly created shipping methods. There are only the default (from demodata) shipping methods, which are selected automaticaly. And that's correct, because when both products are in the basket - none of newly created Shipping Methods fits for this set of products (as these are created only for delivering the particular products).

So, as I understood - there is no bug. Or I misunderstood the situation?

Best regards,

AlxPick

2011-01-14 16:16

reporter   ~0003975

Ok let me describe it better:

- there is a rule for all items, expect category A
- there is a rule for category A with diffrent shipping costs

if I order and article from any category which is not A, costs are correct
if I order a article from category A, it is too

BUT:

if I order an article from any category not A and one from A, I don't get shipping costs correctly.

Depending on how I put them to basket I get either just the any but A one or I get the A one.

There is no way it calcualtes the costs correctly liek it should.

Imagine if we for example sell small hardware and a freezer. The freezer costs 50 Eur shipping, the usale hardware like 5 Eur. Now, if I order both, freezer and some hardware, I don't pay like 5 + 50 Eur, it shows me either 5 Eur or 50 Eur depending on how I put them in basket.

The one going first gives the costs.

Any customer can trick the shop into make it give you 5 Eur as shipping costs for a thing like the freezer by just putting a small thing in basket first.

So it is imposisble to sell things with special shipping price in Oxid currently, even if the option is given.

Is this better explained?

dainius.bigelis

2011-02-07 14:59

reporter   ~0004082

Reminder sent to: AlxPick

Hi,

The situation is clear.
This issue is basically duplicated with the 0002149, and such problem occured after the fix for issue 0001659.
So we will roll-back the fix for 0001659 (so the issues 2149 and this one will work correctly), and 1659 will be solved in different way.
Thank you for your report.
This entry will be marked as duplicate of 0002149

Best regards,

dainius.bigelis

2011-02-07 15:00

reporter   ~0004083

Closed as duplicate of 0002149