View Issue Details

IDProjectCategoryView StatusLast Update
0002257OXID eShop (all versions)1.09. Integrations: Facebook, Trusted Shops, Shop lupe, Econdapublic2012-12-11 08:47
Reportermanuel 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.5 revision 31315 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002257: Econda integration does not work for multishops with seperated URLs
Description/core/smarty/plugins/oxemosadapter.php
<code>
protected function _getScriptPath()
    {
        $myConfig = $this->getConfig();
        $sShopUrl = $myConfig->isSsl() ? $myConfig->getConfigParam( 'sSSLShopURL' ) : $myConfig->getConfigParam( 'sShopURL' );
        return "{$sShopUrl}modules/econda/out/";
    }
</code>

does not work, because the original config path is not the path of the current shopurl.
<code>$sShopUrl = $this->getCurrentShopUrl()</code> should solve the problem
TagsEconda
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

manuel

2010-12-12 15:25

reporter   ~0003805

sry: <code>$sShopUrl = $myConfig->getCurrentShopUrl()</code>