View Issue Details

IDProjectCategoryView StatusLast Update
0002202OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-04-22 08:31
Reporterklaus 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.3 revision 30016 
Target VersionFixed in Version4.4.5 revision 31315 
Summary0002202: Category Sorting in language a affects category sorting in language b
DescriptionI use sorting to get an alphabetic order into the categories.
But the alpabetic order in English and German is different.
E.G.: I create "Adhesives Cat 1000" "Books Cat 2000" ... these categories' sort will apply to the German categories, too, which puts "Klebemittel" before "Buecher".
Correcting the German sorting will affect the English sorting and leave incorrect alphabetic order in English.
TagsCategory
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2010-11-18 10:40

reporter   ~0003709

Fixed "order by" field, now its depends on selected language.

michael_keiluweit

2014-02-12 15:07

developer   ~0009497

reopened this bug, because it is reproduceable in the latest version.

To reproduce it:

1. goto admin
2. administer products
3. categories
4. add category "A" add write "1" into the sort field.
5. add category "B" add write "2" into the sort field.
6. add category "C" add write "3" into the sort field.
7. Copy added categories into language english
8. Change the sorting of the categories while english is activated.
9. switch back to german and have a look at the sort fields. It is exactly what you changed at the english language and not as it was in german.

Linas Kukulskis

2014-03-10 10:50

reporter   ~0009623

categories are loaded with sorting: "oxsort, oxtitle", also oxsort field do not depend on language; its mean that if you enter some sorting it will be the same in all languages; if oxsort field is the same then will be ordered by title (its depend on language). to have possibility sort in different languages independent i will add to feature request list

klaus

2014-04-08 12:26

reporter   ~0009822

Problem looks solved to me:
All categories you want to be sorted in alphabetical order in German as well as in English have to have the same order number.
e.g.:
You have got the categories
"Workmat" - German: "Arbeitsmatte" and
"Batteries" - German: "Batterien".

To sort in alphabetical order, just use the same order number, e.g.: "1000"
Because the order number is the same, Oxid will now sort by category Name.
This will be correct in both English and German language.

English will be

"Batteries"
"Workmat"

German will be

"Arbeitsmatte"
"Batterien"

Now, if you want something like "Special Offers" ( German "Sonderangebote" ) in first place,
make it a lower order number, e.g. "1"
Now you will get the following order in English:

"Special Offers"
"Batteries"
"Workmat"

and in German:

"Sonderangebote"
"Arbeitsmatte"
"Batterien"