View Issue Details

IDProjectCategoryView StatusLast Update
0002074OXID eShop (all versions)5. ------ UpdateApp / Update ------public2011-09-05 12:20
Reporterdeddy 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.2 revision 29492 
Target VersionFixed in Version4.5.3 revision 39087 
Summary0002074: Variants have all disappeared after Update. Only after saving the variants new in backend I can see the variants
DescriptionI've made an update from 3.0.4.1 to the 4.4.1. I used the cumulative update-version. After the update i cannot see the variants in the shop. Only when I'm saving the variants new in the shop-backend, then appears the variants in the frontend.
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

dainius.bigelis

2010-09-06 14:50

reporter   ~0003479

Reminder sent to: deddy

Hi,

We tested the case locally, but we cannot reproduce this issue. It's possible that issue occurs because some specific circumstances.
Could you please help us to debug this case?
What would be useful - to check SQL entries of two parent-articles in oxarticles DB table:
- 1st - parent-article, which not shows the variants in frontend; and
- 2nd - parent-article which is "saved" already in admin and shows variants in frontend.
It would show the difference or data which was corrupted during upgrade.
We would appreciate your help here and feedback about the results.

Best regards,

dainius.bigelis

2010-09-09 18:16

reporter   ~0003493

Closed as cannot reproduce.

deddy

2010-09-10 08:43

reporter   ~0003496

Last edited: 2010-09-10 08:46

View 2 revisions

So sorry I've didn't reply sooner, I've had a mad week.
I've found now the difference. The oxvarcount and the oxvarminprice is null in the table oxarticles. The update didn't observed the variants.

So I need a mysql query to change this. I must count the variants and I need the min price each article.

dainius.bigelis

2010-10-05 10:52

reporter   ~0003573

@Developers: please check if there is a possiblity, that after upgrade from 3rd version eShop (PE 3.0.4.1) it's possible that DB fields oxvarcount and the oxvarminprice are reset to null.
I was not able to reproduce it, but it's possible, that it occurs on some specific conditions (specific product info, etc.).
Just check please, if Update is affecting these fields and how.

Linas Kukulskis

2011-09-05 12:20

reporter   ~0005170

fixed 1.sql update script: un-commented oxminprice flied update
mail fo documentation update