View Issue Details

IDProjectCategoryView StatusLast Update
0002042OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2017-06-23 14:38
Reportercsimon 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Version4.4.1 revision 28950 
Target VersionFixed in Version 
Summary0002042: "Ignore negative Discounts" don't works anymore in 4.4.1
DescriptionFirst translated Bug Report from the German Forums:

Some Articles in Germany (e.g. Books) cannot be discounted by law. Therefore, shop owners use the checkbox "Ignore negative Discounts" for such articles.

In Version 4.3.2 this worked also for Discounts which came from payment methods ("Skonto"), in 4.4.1 this doesn't work anymore.

We've tested it with the Community in an 4.3.2 Enterprise Edition in which the feature Works correctly and the "Skonto" is only calculated of the price of the articles which are not marked with "ignore negative discounts" and the shipping cost.

Well in 4.4.1 demoshop, the Payment Discount is calculated by the whole basket, ignoring the negative Discount Setting.
Steps To Reproduce1. Mark an article with "Ignore negative Discounts"

2. put it in the basket

3. in checkout process, choose "Pay in advance" (you may have to alter the standard discount from "2%" to "1%" since it makes the math easier)

4. Look at the Order overview: The Discount from "Pay in Advance" is applied to the whole basket, but should only for the shipping costs.
TagsDiscount, Payment
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0002166 closed Negative discount is not calculated in the basket 
related to 0004535 acknowledged "Skip all negative Discounts" disables Scale Prices 
related to 0005723 acknowledged Positive discounts in basket 

Activities

dainius.bigelis

2010-08-19 09:42

reporter   ~0003403

This case seems quite confusing because during investigation we noticed that the title of option also the behavior differs in some points. We wrote the request to dev-general mailing list, to clarify what exact behavior users expect from this option.
Waiting for some feedback and then we'll decide how to proceed with solving this case.

Thank you for report.
Best regards,

biebie

2015-02-16 11:33

reporter   ~0010663

Last edited: 2015-02-16 13:41

View 2 revisions

We have the same problem in Oxid Version PE 4.9.0.

Our negative discount is working alright but the "Ignore negative Discounts" on categories doesn't work. Negative discount is calculated for the articles in this categories.

Can you tell me if you are still planning on solving this problem, or is there nobody working on it, for the next time?

Thanks for answer,
Kathleen

JaroslavHerber

2015-02-16 11:51

reporter   ~0010664

Last edited: 2015-02-16 11:53

View 2 revisions

Altough this doesn't make much sense, the "Ignore negative Discounts" also not working with nagative %-discount on shipping costs calculation (oxdelivery__oxaddsum).

Example:
Shipping Cost Rules->Price Surcharge/Discount = -1%

QA

2017-06-23 14:35

administrator   ~0012136

If ignore all neg. discounts is enabled, no negative discounts are calculated for this item regarding discounts and vouchers (see help in Backend).

So payment discounts and delivery discounts are not considered.
So this is not a bug and therefore it will be closed.

QA

2017-06-23 14:38

administrator   ~0012137

See https://bugs.oxid-esales.com/view.php?id=1905