View Issue Details

IDProjectCategoryView StatusLast Update
0001964OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 13:22
ReporterEgoist 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformSuse LinuxOSMacOSXOS Version10.6.4
Product Version4.2.0 revision 23610 
Target VersionFixed in Version4.5.9 revision 43186 
Summary0001964: Incorrect email sender in order confirmation
DescriptionThe order confirmation will be sent to the administrator with the e-mail address of the customer. Not with the e-mail address of the shop.

The order confirmation to the customer's ok.

Should be:
1. it should look like: order confirmation email is sent FROM shop owner TO shop administrator.
2. And when FROM - looks like Shop owner's email, the Reply-To should be customer's email.
TagsOrder
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004238 resolvedaurimas.gladutis Incorrect email sender in contact Form 
related to 0003586 resolvedsaulius.stasiukaitis recommendation emails: "From" raises spam-score 

Activities

Egoist

2010-07-08 12:02

reporter  

fehler.jpg (162,768 bytes)
fehler.jpg (162,768 bytes)

oxy_uttendorfsky

2010-07-27 11:23

reporter   ~0003312

I report the same thing.
There are no receiving email to shop administrator, because of incorrect sender e-mail.

For example google reports error:
Technical details of permanent failure:
Message rejected. Please visit http://www.google.com/mail/help/bulk_mail.html [^] to review our Bulk Email Senders Guidelines.

I think, that correct solution is add replay-to with customer's email and sender email setup to shop administrator's email

Egoist

2010-07-30 17:03

reporter   ~0003342

Yes, I also think that the correct solution.
But unfortunately I have the PE edition. I myself can do nothing in the source code. OXID is responsible for it.

dainius.bigelis

2010-08-13 16:22

reporter   ~0003390

Reminder sent to: Egoist

Hi,

@egoist: you should not change sources anyway - no matter what edtition you use. updating will become a huge amount of work if you 'fix' by changing PHP files.

better use modules - or like you did :) open a change request/fix by this issue tracker :)

to confirm the issue:
- it should look like: order confirmation email is sent FROM shop owner TO shop administrator?
And when FROM - looks like Shop owner's email, the Reply-To should be customer's email?

Best regards,

dainius.bigelis

2010-09-01 15:09

reporter   ~0003464

Reminder sent to: Egoist, oxy_uttendorfsky

Hi,

Could you please check the questions what we have for this case, that you reported some time ago, and give us some details about how exactly it should be fixed according to you?

Best regards,

oxy_uttendorfsky

2010-09-23 12:15

reporter   ~0003545

to confirm the issue:
- it should look like: order confirmation email is sent FROM shop owner TO shop administrator?
And when FROM - looks like Shop owner's email, the Reply-To should be customer's email?

yes.

saulius.stasiukaitis

2012-02-29 12:39

reporter   ~0005836

In file oxemail.php changed line 572 to
$this->setFrom( $oShop->oxshops__oxowneremail->value );