View Issue Details

IDProjectCategoryView StatusLast Update
0001940OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reportermarkus mueller 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.3.2 revision 27884 
Target VersionFixed in Version 
Summary0001940: "Valid with same Series, different Order" option
Descriptioncoupons (numbers) can't be reused 2x, they are always stamped "unvalid".
the only way to use the same coupon Number several times is too issue it many times.

The idea of this is to give out Membership Cards with Numbers which always warant 5% discount.

The option "Valid with same Series, different Order" or in german "G├╝ltig mit gleiche Serie bei einer anderen Bestellung" should make this possible?

Bug or Feature ?
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2010-06-28 08:48

reporter   ~0003225

Reminder sent to: markus mueller

Hi,

I checked the same case on EE 4.3.2 and it works for me:
1. I created coupon with Coupon Number=111111 and Quantity=10.
2. Set the "Valid with same Series, different Order" ON (what means that the same user can use the same coupon "111111" in different orders - if you wanted that case).
3. and performed two separate orders as with same user account using the coupon "111111" - it worked for me in both cases.

On next order I switched the option "Valid with same Series, different Order" to OFF and tried once again to make an order with the same coupon. So it told me:
"Your Coupon 111111 couldn't be accepted.
Reason: Coupon of the same series can't be used in this purchase!"
... what means that option is working.
Maybe I misunderstood this case and doing something wrong to reproduce it. Please describe how to reproduce this case in more details.

Best regards,

markus mueller

2010-06-28 10:08

reporter   ~0003226

OK - comprehension Problem

I want a feature which allows to issue "Customer Cards with Numbers" which never expire. So the feature i need and (for which i understood the Feature "Valid with same Series, different Order" ) is to have the Customer Number and get the Credit - now we have to discuss either
1. anulate the record stamp in the voucher DB
2. ask the Customer to manualy put the first customer in the "group with the special discount"
3. ar and thats my Mistake enter millions of Vouchers of the same Number to enable the customer to use them....

I guess we can move that now to new Feature requests - txs.

birute_meilutyte

2010-08-25 13:59

reporter   ~0003438

Reminder sent to: markus mueller

Hello,

This feature request is moved to feature requests system on oxid.uservoice.com:
http://oxid.uservoice.com/forums/31940-feature-requests/suggestions/1013303

You can register there all requests for new features or system improvements.
Thank you for your idea.

Best regards,