View Issue Details

IDProjectCategoryView StatusLast Update
0001874OXID eShop (all versions)2. ----- eShop backend (admin) -----public2010-09-07 14:47
Reporterdominiks 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.2 revision 27884 
Target VersionFixed in Version4.4.3 revision 30016 
Summary0001874: Online Help is not found when Admin language ID is not 0 or 1
DescriptionAdminister products -> Categories -> Start Help -> Not Found

The requested URL /PE/4.3.2/5/admin/category_main.html was not found on this server.

This problem occurs, when user loged in to Admin area with selected language, which ID is other than 0 or 1. Currently on OXID eSales sites there is Help content placed only in German (lang ID=0) or English (lang ID=1) languages. Means when clicked on the Help link with language ID 5, it requests the Help content in non-existing language form server and gets "Page Not Found".

Please fix it to make such behavior:
- if user loged in to Admin with German or English language: form proper urls to Help with according language (with lang ID 0 or 1). Btw checking should be done by abbreviation, because if language was deleted and then created again - it gets different ID (means English may have ID other than 1).
- if user loged in to Admin with other language than DE or EN - form such links to Help, that user would be directed to English Help page (replace language ID with 1).
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0001683 resolvedvilma_liorensaityte Dyn-Navigation not loaded correctly when using other language than English as second language in Shop 
child of 0001895 resolvedarvydas_vapsva Do not allow to delete default eShop language 

Activities

dominiks

2010-06-02 20:10

reporter   ~0003129

Help is broken for other admin pages as well.

2010-06-03 21:06

 

start-help-404.png (95,896 bytes)
start-help-404.png (95,896 bytes)

dominiks

2010-06-03 21:11

reporter   ~0003141

I keep selecting English language (always) when logging into the admin area, but "Start Help" links are still generated using wrong language ID (5). See attached screenshot start-help-404.png.

dainius.bigelis

2010-06-07 15:12

reporter   ~0003147

Reminder sent to: dominiks

Can you please check what language ID is set for English language in your shop? (Master Settings -> Languages -> Select "English" -> field "Language ID").
If you have inserted some other languages before, and English goes just after those - it's possible, that it got the id=5.
Of course, if this is the case - this place still should be improved. But at least we will know the reason.

Best regards,

dominiks

2010-06-09 12:12

reporter   ~0003160

There is no English language in "Master settings" -> "Languages" list.
There are 2 languages only:

sk - Slovak - ID 3 (active)
de - Deutch - ID 0 (not active)


I'm using English language only when working in admin backend.

dainius.bigelis

2010-06-09 16:05

reporter   ~0003164

This happened because:
you inserted some new languages after DE and EN, so those got IDs 2, 3, and 4.
Then you deleted the English language from Admin -> Languages.
After this step - English language is gone only from eShop frontend, but still available for use in Admin area... which is basically a bug.
Thus - when you login to Admin with "non existing" language, it gets wrong ID (=5 in your case). So the Help is not found then.
Bug should be fixed - to direct user to EN language help in case of "non existing" language is requested.

dainius.bigelis

2010-06-09 17:34

reporter   ~0003165

Basically - we discussed internaly and prepared global concept for preventing such situations and even bigger problems with languages in admin.
See the description of bug and related bugs about following changes.