View Issue Details

IDProjectCategoryView StatusLast Update
0001870OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-12-10 15:34
Reporterjgeissler 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001870: Problems with comments in custom menu.xml file
DescriptionAdd a custom menu.xml in modules/admin/menu.xml with the following content:
-----------------------------------
<?xml version="1.0"?>
<OX>
  <OXMENU id="NAVIGATION_ESHOPADMIN">
    <!-- This is a NON error producing comment ... -->
    <MAINMENU id="dsb_mx_dsb_modules">
      <!-- This is an error producing comment... -->
      <SUBMENU id="dsb_mx_transferer" cl="dsb_transferer" list="dsb_transferer_list">
        <TAB id="dsb_tbcltransferer_main" cl="dsb_transferer_main"/>
      </SUBMENU>
    </MAINMENU>
  </OXMENU>
</OX>
-----------------------------------
When you then execute Administer Users->Admin Roles, you'll get a fatal error like this one:
-----------------------------------
Fatal error: Call to undefined method DOMComment::getAttribute() in <shop path>\tmp\86d354f8ec93b15272f2948d39fa1309^%%94^94F^94FD24E3%%roles_bemain_inc.tpl.php on line 26
-----------------------------------
As soon as you remove the error producing comment, it works again.
TagsNo tags attached.
Theme
Browser
PHP Version
Database Version

Relationships

duplicate of 0001643 resolvedarvydas_vapsva Comments in menu.xml cause problems 

Activities

dainius.bigelis

2010-06-03 14:39

reporter   ~0003133

Bug is duplicated with the 0001643. Priority for this one will be increased.