View Issue Details

IDProjectCategoryView StatusLast Update
0001865OXID eShop (all versions)4. ------ eShop Core -------public2012-12-10 13:42
Reportermonotek 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.2 revision 27884 
Target VersionFixed in Version4.4.0 revision 28699 
Summary0001865: Realpath error on index.php
DescriptionAfter a fresh install of Oxid CE 4.3.2 on Ubuntu 8.04 i get the following error on Oxids index page:

[code]
Warning: realpath(): Unable to access /var/www/oxid/out/basic/oxbaseshop/de/tpl/ in /var/www/oxid/core/oxconfig.php on line 1118
Warning: realpath(): Unable to access /var/www/oxid/out/basic/oxbaseshop/tpl/ in /var/www/oxid/core/oxconfig.php on line 1124
Warning: realpath(): Unable to access /var/www/oxid/out/basic/de/tpl/ in /var/www/oxid/core/oxconfig.php on line 1131
Warning: realpath(): Unable to access /var/www/oxid/out/basic/oxbaseshop/de/tpl/content.tpl in /var/www/oxid/core/oxconfig.php on line 1118
Warning: realpath(): Unable to access /var/www/oxid/out/basic/oxbaseshop/tpl/content.tpl in /var/www/oxid/core/oxconfig.php on line 1124
Warning: realpath(): Unable to access /var/www/oxid/out/basic/de/tpl/content.tpl in /var/www/oxid/core/oxconfig.php
[/code]


This "bug" is due to the inclusion of the Hardened-PHP Project's
Suhosin Patch in many distributions by default (Ubuntu Hardy 8.04 and above for
example).

The suhosin patch replaces PHPs realpath function with the BSD implementation,
which ignores the last path component.

Info about Suhosins realpath replacement:
http://www.hardened-php.net/suhosin/a_feature_list:realpath.html

My PHP runs with mod_fcgid and safe_mode = on (i cant change this).

I hope there will be some kind of workaround.
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

dainius.bigelis

2010-06-03 15:45

reporter   ~0003138

@Developers: this issue needs to be debugged from the source code side with Suhosin installed. Please check it and fix if possible, or suggest some workaround here.

dainius.bigelis

2010-06-08 15:48

reporter   ~0003153

Reminder sent to: monotek

Hi,

Is it possible to debug this case (bug https://bugs.oxid-esales.com/view.php?id=1865) on your testing environment?

Best regards,

monotek

2010-06-09 10:21

reporter   ~0003157

What do you need for this?

Only Url and Admin access or FTP and MySQL too?


P.S.: Joomla Project allready found a fix for this:

http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_id=32&tracker_item_id=20423

arvydas_vapsva

2010-06-09 10:46

reporter   ~0003158

Reminder sent to: monotek

would be nice to have FTP access to be sure if fix really works.

arvydas_vapsva

2010-06-10 14:02

reporter   ~0003169

is_readable( xyz ) || is_dir( realpath( xyz ))

replaced into

is_readable( xyz )