View Issue Details

IDProjectCategoryView StatusLast Update
0001859OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2010-06-15 15:38
ReporterMBa 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.4.0 revision 28699 
Summary0001859: Help-texts makes problems with utf-8
DescriptionWhen you install with utf8 and wanna see the 'default' help text in german
/help/0/default.inc.tpl
you get a white page.
Additional InformationI think its a problem of utf8. If I change in this file

Dieser Standard-Hilfetext erscheint immer dann, wenn es keine spezielle Hilfe gibt. Sie können den Text in der Datei /help/0/default.inc.tpl anpassen.

to

Dieser Standard-Hilfetext erscheint immer dann, wenn es keine spezielle Hilfe gibt. Sie können den Text in der Datei /help/0/default.inc.tpl anpassen.


ö => & ouml;

there is no problem.
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

MBa

2010-05-27 19:10

reporter   ~0003112

wtf
the bugtracker dont display entities.

ö => & ouml;

birute_meilutyte

2010-05-28 10:52

reporter   ~0003113

looks like there is one more problem with help page in Utf-8. in utf-8 and international localization, for EN language DE help text is displayed (check atttached img)

2010-05-28 10:52

 

help.png (5,822 bytes)
help.png (5,822 bytes)

arvydas_vapsva

2010-06-03 12:26

reporter   ~0003131

Advanced users should change help files encoding (from ISO to UTF or any other) manually in case they decided to use non standard encoding in shop. But..

These "help templates" are outdated, so general fix for this problem is to move help pages to CMS/database where all encoding tasks are done automatically when setting up shop.

So by fixing this bug i will:
 - move standard help pages to CMS/oxcontent table;
 - will leave old "help templates" support, but will mark this functionality as deprecated.