View Issue Details

IDProjectCategoryView StatusLast Update
0001544OXID eShop (all versions)6. ------ Setup -------public2015-05-04 15:24
Reporterdainius.bigelis 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.0 revision 23610 
Target VersionFixed in Version4.3.0 revision 26948 
Summary0001544: Check also for mysqlnd driver during system requirements check
DescriptionCurrently when checking for "MySQL module for MySQL 5" in the system requirements check, it checks only for mysql driver.
Since some (prob. 5.3) PHP version there is new MySQL driver available for PHP: mysqlnd (http://dev.mysql.com/downloads/connector/php-mysqlnd/).

Implement check for this driver also in system requirements check and mark as "green" if any of these drivers is installed.
TagsMySQL
ThemeBoth
BrowserAll
PHP Version5.3
MySQL Versionany

Relationships

has duplicate 0001547 closeddainius.bigelis PHP 5.3.0: mysqlnd not recognized 

Activities

nixnutz

2009-12-10 11:00

reporter   ~0002194

Yes, PHP 5.3.0 . This is the best manual page to learn about it: http://de.php.net/manual/en/book.mysqlnd.php . Don't do a hard-wired check on the *exact* mysqlnd version string, it varies by PHP version. Allow some fuzziness.

nixnutz

2009-12-10 11:01

reporter   ~0002195

... and, BTW, switching to mysqli wouldn't be wrong either. It has pconnect, it supports prepared statements and so on.

vilma_liorensaityte

2009-12-15 10:08

administrator   ~0002221

added check for "mysqli" and "pdo_mysql" too