View Issue Details

IDProjectCategoryView StatusLast Update
0000148OXID eShop (all versions)3.1. Design, GUI, UXpublic2008-09-19 10:52
Reporterbirute_meilutyte 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000148: sorting by price not always working
Descriptionsorting by price not always working correctly. see attached img. to reproduce this behavior, use selenium demodata.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

2008-09-18 15:15

 

sorting_by_price.PNG (41,460 bytes)
sorting_by_price.PNG (41,460 bytes)

arvydas_vapsva

2008-09-19 10:50

reporter   ~0000097

there is no bug, just selenium tests must execute following SQL:

UPDATE oxarticles SET oxarticles.oxvarminprice= (select min(art.oxprice) as varminprice from (select * from oxarticles) as art where art.oxparentid = oxarticles.oxid or ( art.oxid = oxarticles.oxid and art.oxparentid = ''));

(at the end of SQL)

arvydas_vapsva

2008-09-19 10:52

reporter   ~0000098

not a bug, see comments