View Issue Details

IDProjectCategoryView StatusLast Update
0001402OXID eShop (all versions)4.06. Language and translationspublic2010-03-25 10:04
Reportersimply because 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.6 revision 22740 
Target VersionFixed in Version4.3.0 revision 26948 
Summary0001402: Newsletter Opt-In
DescriptionIf the shop is running in a second langugae, the link to activate the newsletter subscription is landing on the German language because the language is missing in the link:

[{$oViewConf->getSelfLink()}]cl=newsletter&fnc=addme&uid=[{ $user->oxuser__oxid->value}]

Please add

&lang=[{$oViewConf->getActLanguageId()}]
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

dainius.bigelis

2009-11-03 15:48

reporter   ~0001997

@Developers: please check if there is no similar problem about languages in the order confirmation email.

vilma_liorensaityte

2009-11-05 13:18

manager   ~0002011

Now newsletter subscription link will be generated automaticaly in function _getNewsSubsLink in oxemail.php.

So replace link:
[{$oViewConf->getSelfLink()}]cl=newsletter&fnc=addme&uid=[{ $user->oxuser__oxid->value}]
to:
[{$subscribeLink}]