View Issue Details

IDProjectCategoryView StatusLast Update
0001384OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reporterandreas_ziethen 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.6 revision 22740 
Target VersionFixed in Version4.2.0 revision 23610 
Summary0001384: wrong voucher discount in order emails if foreign currency is used
DescriptionThe order email templates at some places do still use old variables instead of the actual getters. This for example happens in the voucher block and leads to wrong numbers if anoter currency is used.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Relationships

related to 0001305 resolvedsarunas_valaskevicius voucher ignores foreign currencies Min. Order Sum 
related to 0001079 resolvedsarunas_valaskevicius Volume discount calculation with foreign currency works wrong 

Activities

alfonsas_cirtautas

2009-10-23 16:18

reporter   ~0001970

Actually the problem was not in getters, but wrong value stored in oxvouchers__oxdistount table, this was fixed.

Also functionality with deprecated value getters was moved to oxvoucher class, email templates left unchanged.