View Issue Details

IDProjectCategoryView StatusLast Update
0001079OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2012-12-07 15:04
Reportercrest 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.3 revision 19918 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0001079: Volume discount calculation with foreign currency works wrong
DescriptionIf there is a volume discount set in the shop it works fine with the standard currency only. For any other currency it takes the amount as basis and not the equivalent amount.
E.g. volume discount is set to 4% for orders from 100 Euro and above,
6% for 150 Euro and above.
Now a customer puts items of 114 Euro into the basket.
In the cart view it reads correct "Discount 4% from 100 EUR".
If he changes to USD, it says: "USD 154, discount 6% from 150 EUR".

Obviously the effect is even more dramatically in currencies like Yen (exchange rate about 1:132 to the Euro).

Since the same effect occurs in the user groups, we have the impression that the shop has a major problem with handling foreign currencies.
TagsCurrency
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Relationships

related to 0001305 resolvedsarunas_valaskevicius voucher ignores foreign currencies Min. Order Sum 
related to 0001179 closed based on 1079 doesnt work with Currencies without decimal separator and decimal precision = 0 
related to 0001384 resolvedalfonsas_cirtautas wrong voucher discount in order emails if foreign currency is used 

Activities

sarunas_valaskevicius

2009-07-09 17:04

reporter   ~0001173

fixed in discount selection