View Issue Details

IDProjectCategoryView StatusLast Update
0001350OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:29
ReporterBergfreunde 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version4.1.5 revision 21618 
Target VersionFixed in Version 
Summary0001350: Missing advice when oxstockflag = 2 and user tries to buy a higher amount than in stock
DescriptionExample:
- oxstockflag = 2 and there are 10 items of the product on stock
- user is on product-detail-page and puts 20 items into basket

Result:
- amount is reduced to 10, but there is no advice for the user
- the default pop-up with the text "you just added a product to the cart" doesn't keep open

Both can be reproduced in the demo-shops (ee and pe)
TagsProducts
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Relationships

duplicate of 0001274 resolved No oxOutOfStockException Error message returned within details.tpl when oxstockflag=2 (aka 'If out of Stock, offline') 

Activities

philipp_grashoff

2009-09-29 14:28

reporter   ~0001841

Hello,

the missing message is known and will be fixed with 4.1.6, see https://bugs.oxid-esales.com/view.php?id=1274

Bergfreunde

2009-09-30 08:52

reporter   ~0001847

Last edited: 2009-09-30 08:52

I just tried it in demoshop, which is already on 4.1.6 and it still didn't work:
http://demoshop.oxid-esales.com/enterprise-edition/

dainius.bigelis

2009-09-30 19:15

reporter   ~0001858

Reminder sent to: Bergfreunde

Hi,

I tested this once again, and for me it works well in version 4.1.6 (means 0001274 was fixed correctly). Also checked on same demoshop and got such warnings, when tried to add more products than are in stock:
Der Lagerbestand dieses Artikels ist nicht ausreichend! Verf├╝gbar: 10
Not enough items of this product in stock! Available: 10

The same messages are displayed in the product details page also in the basket (if tried to increase amount of products in basket).
Possible, that you tested this on demoshop at the same moment, demoshop was reseted and fresh installation was done (so option oxstockflag = 2 was reset for product). Please check this once again on demoshop.
Currently the entry here is closed. If you will reproduce the bug - please reopen it.

Bergfreunde

2009-10-01 08:39

reporter   ~0001860

Hi,

I tested it again and it didn't change anything. Tested it in EE- and PE-Demoshop in Mozilla and IE.

When increasing the amount in basket all works fine. But when I try to put a higher amount into basket when I am on the product-detail-page there is no message.


My Workflow in PE:
- Login to the backend
- Edit the Article "Bar-Set ABSINTH"
- Set oxstockflag = 2 (Wenn ausverkauft offline / If out of Stock, offline)
- Set amount on stock = 5
- Go into frontend on product-detail-page and put 10 into basket

--> There are 5 Bar-Sets in basket but no message,
that there are no more available

Workflow in EE is the same, just need to update Views at the start



dainius.bigelis

2009-10-22 16:21

reporter   ~0001964

Reminder sent to: Bergfreunde

Hi,

So I checked the same workflow as you described on our demoshops. And still can see the warning message. To be sure that we are talking about the same - I attached the screenshot to the bug entry. Please check it and confirm if you see the same warning.

2009-10-22 16:21

 

screenshot.jpg (112,430 bytes)
screenshot.jpg (112,430 bytes)

Bergfreunde

2009-10-26 09:02

reporter   ~0001972

Hi,

ok I guess I missed the warning, sorry. The default pop-up with the text "you just added a product to the cart" still doesn't keep open. But as you couldn't see the message "Der Lagerbestand dieses Artikels ist nicht ausreichend!" when popup wouldn't close, i think it's a feature and not a bug. If it is, this issue can be closed.

birute_meilutyte

2009-10-28 10:07

reporter   ~0001978

no change required for out of stock message in eshop.
also pop up problem is already fixed in 4.2.0 version (now it keeps open with message about product stock limit)