View Issue Details

IDProjectCategoryView StatusLast Update
0001234OXID eShop (all versions)4.06. Language and translationspublic2009-09-28 14:04
Reporterd3 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.3 revision 19918 
Target VersionFixed in Version4.1.6 revision 22740 
Summary0001234: language specified domain (with own ssl certificate) loses language selection, if ssl will be actived
DescriptionIn our testshop, we defined 3 languages. Every one has got an own domain (e.g. test.de, test.com, test.es) with an own ssl certificate (ssl.test.de, ssl.test.com, ssl.test.es). If user choose another language as the base language und switched to an ssl-based site, die language setting will be lost. Now he get the base language and all of this settings.
If I remove the ssl domains, language will submitted accurately.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

d3

2009-08-25 10:02

reporter   ~0001510

Last edited: 2009-08-25 10:03

- wrong category, it should be located in "core settings"
- we reproduced this problem in Enterprise Edition

dainius.bigelis

2009-08-25 16:31

reporter   ~0001521

For CE and PE shops this case can be solved by setting up the option in config.inc.php:
   $this->sCookieDomain = domain

The domain that the cookie is available. To make the cookie available on all subdomains of example.com then you'd set it to '.example.com'. The . is not required but makes it compatible with more browsers. Setting it to www.example.com will make the cookie only available in the www subdomain. Refer to tail matching in the spec for details.

But this not works in Mall with several shops. So this will be fixed.

arvydas_vapsva

2009-08-26 15:37

reporter   ~0001528

since next release config inc.php will contain two new parameters:

    // The domain that the cookie is available: array( _SHOP_ID_ => _DOMAIN_ );
    // check setcookie() documentation for more details @php.net
    $this->aCookieDomains = null;

    // The path on the server in which the cookie will be available on: array( _SHOP_ID_ => _PATH_ );
    // check setcookie() documentation for more details @php.net
    $this->aCookiePaths = null;

On special cases which may not cover your needs you can simply write a modules for oxUtilsServer::_getCookieDomain()/oxUtilsServer::_getCookiePath().