View Issue Details

IDProjectCategoryView StatusLast Update
0001056OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 13:24
Reportertjungcl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.3 revision 19918 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0001056: No time-out or error-handling for VIES web-service
DescriptionThe check for ust-ids accesses
http://ec.europa.eu/taxation_customs/vies/api/checkVatPort?wsdl

If that service is down, the user gets an error-message after clicking next-step. If that service is slow, the user waits a few minutes after clicking next-stop (probably he will NOT wait, but exit the shop and wont order...)

The VIES service should have a short timeout (five seconds f.e.) and should proceed to payment-step, when it gets no answer in the given time.

The plausiblity-check of a given ust-id is not important enough to risk loosing a customer in the checkout.

TagsOrder
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

tomas_liubinas

2009-07-02 20:23

reporter   ~0001141

I added 5 sec timeout. Lets discuss more what should happens when service has not been reached. Unfortunately I cannot write unit tests for this case, due to outside connection.

vilma_liorensaityte

2009-07-28 12:32

administrator   ~0001288

Last edited: 2009-07-28 13:09

After checking code:
if service is not available, user can continue with order without any message and VATID status will be set to "0" (oxustidstatus field in oxuser table)