View Issue Details

IDProjectCategoryView StatusLast Update
0001127OXID eShop (all versions)4. ------ eShop Core -------public2012-12-10 13:42
Reporterd3 
PriorityhighSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.1.3 revision 19918 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0001127: "Notice: Undefined variable:" because of oxsession.php
DescriptionIn some cases we get this error in browser and active error_reporting "E_ALL" in PHP:

"Notice: Undefined variable: ‹ÿ;^\×Þâ\ in ../core/oxsession.php on line 412"


Seems that you should add isset() in this line:

            if ($blForceSID) {
                $url .= 'force_sid=' . $this->getId() . '&';
            }
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Activities

dainius.bigelis

2009-07-23 11:55

reporter   ~0001269

@Developers: please check the issue from the source code side and fix if needed.