View Issue Details

IDProjectCategoryView StatusLast Update
0000955OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:45
Reporterd3 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.2 revision 18998 
Target VersionFixed in Version4.1.3 revision 19918 
Summary0000955: each call on oxDelivery::getDeliveryPrice() changes the Price
DescriptionI need to get the price from an oxDelivery instance. In oxDelivery, there is no getPrice() method so i have to use getDeliveryPrice() (it´s the only method retuning an oxPrice instance).
But on each call the Price changes, because $this->_oPrice->add(); is executet every time (line 279 and 284).
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Activities

arvydas_vapsva

2009-06-02 10:39

reporter   ~0000999

oxdelivery::getDeliveryPrice() now does not recalculate price on each call (caches value in oxdelivery::_oPrice property), additionally introduced oxdelivery::setDeliveryPrice(), which allows to reset (when setting value to null) or set alternative delivery price