View Issue Details

IDProjectCategoryView StatusLast Update
0000795OXID eShop (all versions)3.1. Design, GUI, UXpublic2009-04-14 11:20
Reporteralfonsas_cirtautas 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.0 revision 17976 
Target VersionFixed in Version4.2.0 revision 23610 
Summary0000795: IE8 (strict mode) popup mask is not transparent
Descriptionif IE8 is not in compatibility view mode, black popup mask is not transparent
Additional InformationDue to IE8 css parser changes following expression doesn't work anymore

   filter:Alpha(Opacity=0)

it has to be replaced with filter:

   -ms-filter: "progid:DXImageTransform.Microsoft.Alpha(Opacity=0)";


TagsNo tags attached.
Theme
BrowserInternet Explorer 8.x
PHP Version5.2.6
Database Version5.0.33

Activities

2009-04-14 11:02

 

ie8_opacity_problem.png (364,061 bytes)

alfonsas_cirtautas

2009-04-14 11:14

reporter   ~0000753

quick fix is to add the following lines after css includes in _header.tpl and _header_plain.tpl files

<!--[if IE 8]><style type="text/css">
#mask.on,div.bar.links a.language.act img,#body #demoAdminLink {-ms-filter:"progid:DXImageTransform.Microsoft.Alpha(Opacity=70)";}
</style><![endif]-->

alfonsas_cirtautas

2009-04-14 11:18

reporter   ~0000754

Fixed new ie8 opacity filter syntax, + IE css compatibility files slitted to different files depending on version