View Issue Details

IDProjectCategoryView StatusLast Update
0007124OXID eShop (all versions)6. ------ Setup -------public2020-04-20 11:04
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionopen 
Product Version6.2.0 
Target VersionFixed in Version 
Summary0007124: Module with error in metadata cannot be removed
DescriptionIf you try to install a module that has an incorrect metadata, installation fails, but deinstallation is not possible.
Steps To Reproduce1. execute: composer require linslin/oxid6-example-module
    Installation fails, composer.json is reverted
   At this point, the module has already been downloaded by composer
2. execute: composer update
   Update also fails, although module is no longer present in composer.json:
  [OxidEsales\EshopCommunity\Internal\Framework\Module\MetaData\Exception\UnsupportedMetaDataKeyException]
  The metadata key "files" is not supported in metadata version "2.0".
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

QA

2020-04-20 09:10

administrator   ~0013189

Hi leofonic,

in my reproduction process with version 6.2 I can verify that the installation fails, also the composer update, but in my system, he doesn't remove the failed module entries in composer - data.
could you please check, if in the composer.json and composer.lock the module entries still exist?

I removed the entries in composer.json, composer.lock and vendor/composer/installed.json, then composer update worked.

Best Regards

leofonic

2020-04-20 11:04

reporter   ~0013191

> could you please check, if in the composer.json and composer.lock the module entries still exist?

composer.json: no entry, it was reverted after installation failed. Composer.lock is not read by composer update i think.

I think it should not be necessary to manually remove the module from vendor/composer/installed.json, errors in metadata could be ignored by oxid compooser plugin on deinstallation.