View Issue Details

IDProjectCategoryView StatusLast Update
0007123OXID eShop (all versions)6. ------ Setup -------public2022-06-22 16:43
Reporterleofonic 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.2.0 
Target VersionFixed in VersionNext Minor Version 
Summary0007123: Removal of require-dev not possible
DescriptionOnce composer has been run without --no-dev, update with --no-dev is no longer possible
Steps To ReproduceInstall 6.2.0 without --no-dev
run composer update --no-dev

An exception is thrown:
Warning: Uncaught ErrorException: require(/var/www/html/vendor/composer/../ralouphie/getallheaders/src/getallheaders.php): failed to open stream: No such file or directory in /var/www/html/vendor/composer/autoload_real.php:73
Additional Information- es -
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Relationships

has duplicate 0007185 acknowledgedbenjamin.joerger Removing dev packages leads to error at Composer execution 

Activities

anton.fedurtsya

2022-06-22 16:43

administrator   ~0013830

Looks like PR-27 (https://github.com/OXID-eSales/oxideshop_composer_plugin/pull/27) fixing the issue.