View Issue Details

IDProjectCategoryView StatusLast Update
0007111OXID eShop (all versions)4.08. Cachepublic2020-05-13 09:15
ReporterQA 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.2.0 
Target VersionFixed in Version6.2.1 
Summary0007111: Path of file container_cache.php is always default tmp directory (hardcoded)
DescriptionIn the config.inc.php file you can define a custom path for your temporary directory. Default is source/tmp.

$this->sCompileDir = '/var/www/oxideshop/source/tmp';

Unfortunately the path to the file container_cache.php is always the default path since it's hardcoded to your source directory + 'tmp'.

See in code:

OxidEsales\EshopCommunity\Internal\Transition\Utility\BasicContext

public function getContainerCacheFilePath(): string
{
    return Path::join($this->getSourcePath(), 'tmp', 'container_cache.php');
}

Function getConfigParam('sCompileDir') should be used instead.
Additional InformationIf you did not delete the default tmp directory, the eShop works by using this directory for the one file. Anyway, it does not look correctly.

[sp]
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

Igor Iegupov

2020-04-21 12:24

developer   ~0013194

Fixed in 6.2.1