View Issue Details

IDProjectCategoryView StatusLast Update
0006812OXID eShop (all versions)2.6. Administer orderspublic2018-03-26 15:51
Reporterhenrik.steffen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version6.0.1 
Target VersionFixed in Version 
Summary0006812: Manually added discount is lost when recalculating order
DescriptionIf merchant should use "order -> main" tab to add a manual discount to an existing order, this discount will be lost, as soon as he goes to "order -> products" tab and hits the "update" button, cancels or deletes or adds an item.
The discount will either be removed, or any discount which is currently active in the shop for the current basket will be applied.
Steps To Reproduce1. place an order (without any discounts)
2. go to admin -> orders -> main and add 10 € discount
3. go to admin -> orders -> products and click "update" button
4. discount is removed

Additional Information

This bug has probably the same cause as https://bugs.oxid-esales.com/view.php?id=4624
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

There are no notes attached to this issue.