View Issue Details

IDProjectCategoryView StatusLast Update
0006606OXID eShop (all versions)4.07. Source code, Testpublic2019-12-02 13:25
Reporterhenrik.steffen 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.10.3 / 5.3.3 
Target VersionFixed in VersionPatch for 6.1 
Summary0006606: Blacklisted by example.com / point checkAllowUrlFopen() to another destination in oxsysrequirements.php
DescriptionWay back in 2009 the url for testing if fsockopen is available on a host system was changed to test if www.example.com can be reached.

Well... we actually got blacklisted by example.com. They do not accept any IP-traffic from our whole network infrastructure anymore.

Probably due to the reason that we host lots of OXID eShops in our network, which all query www.example.com everytime an admin logs into the back-end.

Can you please modify the checkAllowUrlFopen() somehow, so it would either check for a different URL, or maybe even just localhost ? Or maybe amazon.com or google.com ? Or maybe the check can be disabled or configured to a custom URL ?

Right now, all our hosted shops show a "!" symbol in the setup routine and also when looking at the system requirements page for the check "allow_url_fopen or fsockopen on Port 80"
TagsSolution Provided
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0001033 resolvedtomas_liubinas point checkAllowUrlFopen() to another destination in oxsysrequirements.php 

Activities

henrik.steffen

2017-03-21 16:00

reporter   ~0012000

ah, by the way, this has been an issue way back in 2009:

0001033

alfredbez

2017-03-28 16:23

reporter   ~0012005

PR: https://github.com/OXID-eSales/oxideshop_ce/pull/556

anton.fedurtsya

2019-12-02 13:25

manager   ~0013063

Merged with a little adjustement.