View Issue Details

IDProjectCategoryView StatusLast Update
0006506OXID eShop (all versions)2.3. Extensions (modules, themes)public2016-09-19 07:40
Reporteravalue 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.9.9 / 5.2.9 
Target VersionFixed in Version 
Summary0006506: Extended Classes case-sensitive must be checked
DescriptionIf you - by mistake - extend "oxBasket" instead of "oxbasket", it will actually seems to work as expected but another modules are not able to load their declared functions. It can sometimes happen and then the shop backend SHOULD throw an error message or the module should not be able to activate.

In our case customer could not pay anything for two days because the other modules that extended oxbasket stopped working.

Please do not simply write "use lowercase". A error message in backend should be thrown or it should simply not work.
Steps To ReproduceWrite a module that extends "oxBasket" (notice the uppercase B) and do something. Use for example PayPal or Sofort├╝berweisung Module - it will not work and users can not finish their order.
TagsNo tags attached.
ThemeNot defined
BrowserGoogle Chrome
PHP Version5.6
MySQL VersionNot defined

Relationships

duplicate of 0005687 assignedDariush Ghiass-Fakhri Module chain is case sensitive 

Activities

There are no notes attached to this issue.